NH Frag Swap

Full Version: Filamentous algae all over my macro
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2
So I've been slowly watching my ball of cheato, caulerpa and titan slowly grow from a handful to a bunch. Lately I've been getting a lot of hair or other filamentous algae encompassing my caulerpa and titan. It doesn't seem to encompass the chaeto.

My question is, is this normal? Something to be concerned with?

I only run GFO. I test nitrates every week or so and I can't detect anything more than 1-2 ppm when do test.


Sent from my iPhone using Tapatalk

[Image: 07259fe5c6dc660a67d1a20522da1f66.jpg]

It's not a great picture of it, but.... pics for clicks!!!


Sent from my iPhone using Tapatalk
Wow they are covered! I would guess it to be hair algea but im not sure that is weird that its just growing around the macros im curious to see if anyone else know about this. Do you good circulation in there? Maybe its just leaching to the macros because of their nutrients

Sent from my SM-G935P using Tapatalk
What kind of light are you using on there and how long is it on?
+1 on the circulation.  If you are running cheato in there you literally want to having tumbling or close to it.  Also, what is your phosphate reading at?  Do you have a good population and good diversity of pods, worms, etc. growing in the fuge?  The Phosphate/Phosphorus levels will be more of an issue than the Nitrate when it comes to nuisance algae.
So the light is a homemade led light. It's made up of 6500k and blue. It has a couple reds mixed in. Maybe around 15 Cree leds


Sent from my iPhone using Tapatalk

The light is on roughly opposite of my tank lights, about 12 hours.

I don't have a good phosphate test. I tried to seed some tigger pods a few weeks ago. Worms, I'd assume so.

I'll have to figure out some better circulation. I have an extra powerhead that's small and may work




Sent from my iPhone using Tapatalk
Even a small powerhead will definitely help

Sent from my SM-G935P using Tapatalk
Light really shouldn't matter.  What is your PO4 reading at?
No way to check po4 but have been running GFO for a couple months


Sent from my iPhone using Tapatalk
Can you get a closer pic? Just want to be sure of the type of algae.
Pick up a quality Phosphate and/or Phosphorus test kit.  Having that parameter data on your systems will benefit your overall system health well beyond just controlling algae.
Pages: 1 2